M&K Junction Railroad

M&K Junction Railroad
Another train of eastbound coal crosses the Cheat River

Saturday, May 23, 2015

An Electrical Makeover



While I have reduced the frenetic pace that I was applying to building the layout; I'm still moving forward.  I promised myself that I would pause here and upgrade the layout's electrical system.  

As I built the track work, I installed all of the track feeders and buses, plus made provisions for power districts; it would have been very difficult to retrofit this work.  However, there are jobs that need to be done to get to the final electrical/electronic configuration of the layout.  Here's a list of the things that I intend to do before moving on to other, more visible, tasks:

  • Upgrade the layout's power from 16 to 32 amps.
  • Divide the layout into power districts. My current thinking is that 4 districts are required.
  • Install the remaining switch machines and power the frogs; removing the "temporary" hard wiring of frogs that was put in place.
  • Add more plug-in stations around the newly completed parts of the layout for wired throttles.
  • Install more radio throttles.
  • Get JMRI working so that the layout can be automated and WiFi tablets can be used for throttles.

Why, you would rightly ask, would I need wired, radio and WiFi throttles?  Well, I have the wired throttles and, with the Lenz system, they are handy for on-the-fly reprogramming of locos.  My guests "get" wired throttles; but don't like them.

Nowadays, most operators expect to use radio throttles.  Lenz uses cordless phones as radio throttles.  The phone's keypad is used for control. I find this system really slick and I can work the throttle one-handed and without looking; my thumb plays the keypad like a virtuoso. Unfortunately, most of my guest operators have a difficult time with this system.  Almost everyone else runs NCE systems and is familiar with their radio throttles.

JMRI and WiFi throttles are where I want to go.  However, no one in our round-robin group uses this technology and I don't expect that it will be readily accepted.

Also note that heretofore the entire layout was running on a single 5 amp command station.  It's actually miraculous that this system could drive that great a length of track and bus.

This work has begun and I am tackling the tasks in more or less random order, as the mood hits me or as I run into problems or run out of supplies on any given task.  

Below are pictures of the upgraded power.  I added a second transformer to the one that was already powering the layout.  Each is capable of providing, theoretically, 16 amps at 14 VAC.   They are housed in a discarded computer case. The primary side of the transformers is fused and the outputs are ganged together then feed (3) 10 amp fused circuits.  This will supply 3 power districts of 5, 10 and 10 amp capacity. By keeping this in one housing, I can shut down track power with a single switch.  Ganging the outputs together eliminates any issues with common grounds.  While separating the output into (3) 10 amp fused circuits prevents 32 amps from flowing to any booster or through layout wiring.




Why, you could ask, did I use "old school" transformers when, elsewhere on this blog, I advocate for using reworked PC power supplies?  I bought these two hulking transformers before I thought of the idea of using PC supplies and the Lenz command station and boosters, take in AC.

All was in readiness.  I wired the AC to the location of the first 10 amp booster to be added, the control and cab buses had been wired at that site previously.  I disconnected that power district from the rest of the layout.  I triple checked all of my wiring; the Lenz 10 amp boosters are no longer made and it took me years to find some on e-bay - I did not want to blow one out.  When power was finally applied the LED on the remote booster was winking at me.  It seems that the booster was not seeing a signal on the control bus.  Whiskey, Tango, Foxtrot !!!  I checked the wiring again, substituted the other booster; no luck.  I checked the control bus signal at the command station - 12.7 V; at the booster it was 1.7V !!  DUH! I would not have thought there would be that much voltage drop in 40 feet or so.  

The boosters are placed as near to the center of their power districts as possible.  I don't want to move them closer to the centrally-located command station. I spent this morning looking at potential buffer circuits for the control bus.  This is going to be a major PITA.

A couple of weeks ago, I tackled some frogs on turnouts and a curved crossover inside the helix.  I had 2 Tam Valley Depot dual frog juciers on hand.  I put them in a nice plexiglass enclosure so I can see the blinky lights; wired them up (had to pay an outrageous price for a terminal strip at Radio Shack rather than lose time and wait for one to come mail order) and they worked fine.  Except for one loco (a Sunset B&O Q4b steamer with a Digitrax decoder).  This loco would cause the frog to flip to the wrong polarity and then stall in the turnout.  It's not the frog juicer's fault.  I experimented with using a 2 ohm 10 watt resistor to simulate a 4 amp load on the frog - it switched correctly every time.  There is something squirrely (or should that be froggy?) going on with this locomotive.  I have to experiment some more.  I can always revert to relays here to switch the frogs. The Tam Valley quad PIC servo controller supports them and I have some on hand.


(2) Dual Frog Juicers

The installation of the new radio throttles went somewhat better.  Most units on the Lenz throttle bus connect via a DIN plug; but the XPA phone adapter connects via an RJ11/12 telephone-type plug. I had previously figured out how the telephone cables that Lenz provides to wire up their XPA phone adapter work (did you know there is a "data" phone cable that is different from the "telco" one that you buy at the store?).  I wired up some of these to fit the my installation.  I addressed the XPA adapters at XpressNet addresses 15, 16, and 17 - right in the middle of the address range.  


The XPA Adapters


A Phone Throttle

I tried each one of the three cordless phones that I had (2 old, disused phones and a new DECT model).   All worked individually. However, they would not work together! Oh No! Long story short, the old 900 MHz phone was interfering  with the new 1.9 GHz DECT phone and vice versa.  I would have thought that 1 GHz frequency separation was sufficient, but no.  Neither one would work if the other was transmitting. The old 2.4 GHz phone worked fine with the DECT or the 900 MHz.  I'll replace the 900 MHz unit (too bad, this one had been my workhorse phone throttle)

Twice stymied of late, I spent this afternoon at the low tech task of wiring up DIN plugs to extend the wired cab bus.  I caught one wiring error.  I got 3 plugs wired (out of 6 needed) before running out of ring terminals.  Tomorrow I'll get some more and, hopefully, I can finish this task without incident this weekend.

For someone who knows wiring and electronics, this is a pretty low batting average.  As I said in a previous post - nothing goes as quick as expected.









No comments:

Post a Comment